400-886-8010/027-87158220

全国免费服务热线

您当前的位置:首页> 视频下载> 技术资讯> ICT技术资讯

ICT技术资讯

【实战案例】S系列交换机与微软NLB服务器直连做网关(交换机组成VRRP备份组且物理链路环回)

发布时间:2016-05-06浏览次数:


网络负载均衡NLB(Network Load Balance)是微软在Windows Server上开发的多服务器群集负载均衡特性。对于使用Windows Server的企业来说,实现设备与NLB服务器群集的对接非常重要。本文描述了S系列交换机与NLB服务器群集直连做网关的场景分析和配置过程。

 

背景知识

在NLB服务器群集中,每台服务器都有自己的IP地址和MAC地址。同时,NLB服务器群集还有一个单播的虚拟IP地址和一个虚拟MAC地址,分别称为群集IP地址和群集MAC地址。NLB群集通过该IP、MAC和做网关的S交换机直连互通,交换机通过三层转发将网络侧的流量同时同时转发一份给NLB集群中每一台服务器,然后NLB集群服务器内部通过特定算法实现负载分担,决定由哪一台服务器向网络侧回应报文。

 

目前,NLB服务器支持单播模式、组播模式和IGMP多播模式三种工作模式。

 

对接分析

三种工作模式下,S交换机与其对接做网关时存在的问题如下:

  • 单播模式:单播群集MAC地址以02bf开头(单播MAC)。S交换机与单播模式的NLB服务器群集对接时,对应群集IP地址的ARP表项只能学习到一个出接口。因此,只有一台NLB服务器会收到发往群集IP地址的报文。

 

  • 组播模式:组播群集MAC地址以03bf开头(组播MAC)。S交换机与组播模式的NLB服务器群集对接时,由于缺省情况下,S交换机无法学习到MAC地址是组播MAC的ARP表项。通过使能动态学习组播MAC的功能或静态ARP表项绑定的方式,也只能学习到一个出接口。因此,只有一台NLB服务器会收到发往群集IP地址的报文。

 

  • IGMP多播模式:IGMP多播群集MAC地址以0100-5e开头。目前,S交换机不支持与工作在IGMP多播模式的NLB服务器对接。

 

如上分析,必须解决只能发送一台服务器的问题,S交换机和NLB服务器才能实现对接。

 

对接方案

多端口ARP方案:多端口ARP可以实现将发往服务器群集的报文同时发送给群集中所有的服务器。多端口ARP主要通过静态ARP表项将NLB群集IP地址与NLB服务器群集使用的共同MAC地址进行绑定,并且通过多端口MAC表项将NLB服务器群集使用的共同MAC地址与设备上与服务器相连的出接口进行绑定。这样发往服务器群集IP地址的数据报文会从设备上所有与服务器相连的出接口发送出去。 这种方案适用于S交换机V200R003C00及以后版本。

 

对于V200R003之前的版本,可以通过如下两种方式实现对接:

  • 在交换机与NLB服务器之间增加二层交换机(当NLB服务器工作在组播模式时,需要在交换机上使能ARP动态学习组播MAC的功能或者配置静态ARP表项)。这种方法需要多增加一台二层交换机,适用于设备资源充足的情况。

 

  • 物理链路环回方法。这种方法与增加二层交换机的方法相比,配置较复杂。

 

对接案例1——多端口ARP方案(V200R003及以后版本)

第一期我们已经介绍了这个方案的实现过程,具体请参考:http://support.huawei.com/ecommunity/bbs/10237713.html

Note:部分盒式款型不支持,帖子里都有介绍。

 

对接案例2、3——增加二层交换机&单台设备物理链路环回

对于不支持多端口ARP的设备形态,在设备条件满足的情况下,通过增加二层交换机的方法,可以实现设备与NLB服务器群集的对接。

 

单台设备物理链路环回方案适用于S系列交换机所有产品形态及版本。但这个方案需要占用物理端口资源,支持多端口ARP的情况下,推荐使用多端口ARP。

 

具体请参考:http://support.huawei.com/ecommunity/bbs/10238288.html

 

对接案例4——交换机组成VRRP备份组且物理链路环回

本方案适用场景同“单台设备物理链路环回”,不同之处在于作为网关的交换机设备不再是单台设备,而是一个VRRP备份组。下面我们举例说明:


 组网需求

如下图所示,交换机Switch_1和Switch_2通过接口GE0/0/2相连的心跳线组成VRRP备份组,其中Switch_1为主、Switch_2为备。Switch_1和Switch_2上的接口GE0/0/1分别与两台NLB服务器直连。NLB服务器群集工作在组播模式下,群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fc。Switch与客户端Client之间路由可达。

 

当客户端Client访问NLB服务器群集时,VRRP备份组能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。


数据规划 

在开始配置之前,需要规划好以下数据。


配置思路

通过物理链路环回方法实现对接的配置思路如下:

1.配置与NLB服务器直连的接口GE0/0/1加入VLAN100。
2.配置心跳线接口GE0/0/2加入VLAN100。
3.去使能自环接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100和VLAN200。
4.配置三层接口VLANIF200的VRRP虚拟IP地址,该VRRP虚拟IP地址作为NLB服务器群集的网关。
5.配置静态ARP表项。静态ARP表项的IP地址为群集IP地址,MAC地址为群集组播MAC,出接口为自环口上NLB服务器群集网关VLAN所在的接口。
6.连接自环接口GE0/0/4和GE0/0/5。 
 

操作步骤 
1.   配置与NLB直连的接口GE0/0/1

# 在Switch_1上配置接口GE0/0/1加入VLAN100。

<Quidway> system-view

[Quidway] sysname Switch_1

[Switch_1] vlan batch 100 200

[Switch_1] interface gigabitethernet 0/0/1

[Switch_1-GigabitEthernet0/0/1] port link-type access

[Switch_1-GigabitEthernet0/0/1] port default vlan 100

[Switch_1-GigabitEthernet0/0/1] quit

 

# 在Switch_2上配置接口GE0/0/1加入VLAN100。

<Quidway> system-view

[Quidway] sysname Switch_2

[Switch_2] vlan batch 100 200

[Switch_2] interface gigabitethernet 0/0/1

[Switch_2-GigabitEthernet0/0/1] port link-type access

[Switch_2-GigabitEthernet0/0/1] port default vlan 100

[Switch_2-GigabitEthernet0/0/1] quit

 

2.   配置心跳线接口GE0/0/2加入VLAN100

# 在Switch_1上配置接口GE0/0/2加入VLAN100。

[Switch_1] interface gigabitethernet 0/0/2

[Switch_1-GigabitEthernet0/0/2] port link-type trunk

[Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100

[Switch_1-GigabitEthernet0/0/2] quit

 

# 在Switch_2上配置接口GE0/0/2加入VLAN100。

[Switch_2] interface gigabitethernet 0/0/2

[Switch_2-GigabitEthernet0/0/2] port link-type trunk

[Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100

[Switch_2-GigabitEthernet0/0/2] quit

Note:心跳线接口不能加入自环口上网关所在的VLAN,防止流量在VRRP备份组设备间循环。例如,该举例中GE0/0/2不能加入VLAN200。

 

3.   配置自环接口GE0/0/4和GE0/0/5

# 在Switch_1上去使能接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能。

[Switch_1] interface gigabitethernet 0/0/4

[Switch_1-GigabitEthernet0/0/4] undo stp enable

[Switch_1-GigabitEthernet0/0/4] quit

[Switch_1] interface gigabitethernet 0/0/5

[Switch_1-GigabitEthernet0/0/5] undo stp enable

[Switch_1-GigabitEthernet0/0/5] quit

 

# 在Switch_1上配置接口GE0/0/4和GE0/0/5以Access类型分别加入VLAN100和VLAN200。

[Switch_1] interface gigabitethernet 0/0/4

[Switch_1-GigabitEthernet0/0/4] port link-type access

[Switch_1-GigabitEthernet0/0/4] port default vlan 100

[Switch_1-GigabitEthernet0/0/4] quit

[Switch_1] interface gigabitethernet 0/0/5

[Switch_1-GigabitEthernet0/0/5] port link-type access

[Switch_1-GigabitEthernet0/0/5] port default vlan 200

[Switch_1-GigabitEthernet0/0/5] quit

 

# 在Switch_2上去使能接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能。

[Switch_2] interface gigabitethernet 0/0/4

[Switch_2-GigabitEthernet0/0/4] undo stp enable

[Switch_2-GigabitEthernet0/0/4] quit

[Switch_2] interface gigabitethernet 0/0/5

[Switch_2-GigabitEthernet0/0/5] undo stp enable

[Switch_2-GigabitEthernet0/0/5] quit

 

# 在Switch_2上配置接口GE0/0/4和GE0/0/5以Access类型分别加入VLAN100和VLAN200。

[Switch_2] interface gigabitethernet 0/0/4

[Switch_2-GigabitEthernet0/0/4] port link-type access

[Switch_2-GigabitEthernet0/0/4] port default vlan 100

[Switch_2-GigabitEthernet0/0/4] quit

[Switch_2] interface gigabitethernet 0/0/5

[Switch_2-GigabitEthernet0/0/5] port link-type access

[Switch_2-GigabitEthernet0/0/5] port default vlan 200

[Switch_2-GigabitEthernet0/0/5] quit

 

4.   配置NLB服务器群集网关的IP地址

 

# 在Switch_1上创建VRRP备份组1,配置Switch_1在该备份组中的优先级为120。

[Switch_1] interface vlanif 200

[Switch_1-Vlanif200] ip address 10.128.246.10 24

[Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //配置VRRP组1的虚拟IP地址为10.128.246.250,这个地址作为NLB服务器群集的网关

[Switch_1-Vlanif200] vrrp vrid 1 priority 120 //优先级设置为120,高于缺省的100,这台设备会成为VRRP主

[Switch_1-Vlanif200] quit

 

# 在Switch_2上创建VRRP备份组1,配置Switch_2在该备份组中的优先级为缺省优先级100。

[Switch_2] interface vlanif 200

[Switch_2-Vlanif200] ip address 10.128.246.11 24

[Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //配置VRRP组1的虚拟IP地址为10.128.246.250,这个地址作为NLB服务器群集的网关

[Switch_2-Vlanif200] quit

 

NLB服务器群集的网关与其他服务器的网关可以共用吗?

不建议将NLB群集网关和其他服务器的网关设置成同一个,这是因为在物理链路环回的这种组网中,本端设备发往NLB服务器群集的流量会通过心跳线发往对端设备,并经过对端设备的自环线。此时,如果其他服务器与NLB服务器具有相同网关,会导致其他服务器也收到发往NLB服务器群集的流量,给网络增加负担。例如:由Switch_1发往群集IP的流量会通过心跳线发往Switch_2。在Switch_2上,由自环口GE0/0/4通过自环线到达GE0/0/5。如果此时Switch_2上的非NLB服务器的网关也是VLANIF200。该流量就会由自环口GE0/0/5发往非NLB服务器。

 

5.   配置静态ARP表项 //NLB服务器群集工作在组播模式,必须配置静态ARP表项

# 在Switch_1上配置静态ARP表项的IP地址为群集IP地址10.128.246.252,MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5。

[Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

 

# 在Switch_2上配置静态ARP表项的IP地址为群集IP地址10.128.246.252,MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5。

[Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

 

6.   连接自环接口GE0/0/4和GE0/0/5

上述配置完成后,在Switch_1和Switch_2上分别进行物理连线。

 

7.   验证配置结果

上述配置完成后,发往NLB服务器群集IP地址的报文Server_1和Server_2都能收到。 

 

配置步骤&配置文件

1、点击左下角阅读原文查看。

2、在电脑上下载。

 

如何在电脑上下载本案例配置文件?

步骤一:在百度中搜索“交换机案例”

步骤二:进入“★火★【汇总贴】【交换机在江湖】

步骤三:在目录中找到本案例,下载附件即可。